Aug 21, 2012

openSUSE 12.2 RC2 Install Notes

openSUSE 12.2 RC2 Install Notes

I choose  openSUSE 12.2 RC2  x86_64 Version

Some packages you may install.....

Google Chrome

  • Just download and install it.  :-)


  •  You could use one click install to install dropbox.
  • I use  home:opensuse_zh repo to install  dropbox and  nautilus-dropbox
  • After install dropbox and nautilus-dropbox packages, run the command at gnome terminal >dropbox  start  -i 

Input method for Asia people is gcin, so I keep it


  • # zypper  install  pidgin
  • I use zypper  to install pidgin for IM (MSN / Google talk). 

Add  Packman mirror repo in Taiwan.
Use shell script to add Packman repo.
For example, if the shell script name is ""

echo "Print the rep  in use"
zypper  lr -u

#Define openSUSE Version
VERSION=`cat /etc/SuSE-release | grep VERSION | cut -d ' ' -f 3`
echo "This openSUSE version is $VERSION"

echo "Add Taiwan's rep "

## for Packman Rep
zypper  ar -f$VERSION/ NCHC-Packman
#zypper ar -f$VERSION/ twaren_packman
zypper  mr  -p  98  NCHC-Packman


After add Packman repo, I use zypper command to install Mplayer and smplayer package.

#zypper   install  -y  -l   MPlayer   smplayer   smplayer-lang


Last version for linux is, and current version for linux is
I use command line ( wget ) to get the skype package

#wget  -O  skype-`date +%F`.rpm

The download package name will be "skype-yyyy-mm-dd.rpm"

For rpm base OS, Skype only provide 32 bits packages, so you must install some packages first.

You can see
But it's not enough, for example, you should install  libXss1-32bit  package too. ( Not list on wiki)

You can use command line to do it.

#zypper   install   libpulse0-32bit

#zypper   install   xorg-x11-libXv-32bit   libqt4-32bit   libqt4-x11-32bit   libpng12-0-32bit

#zypper  install libXss1-32bit

Install  skype package

#rpm  -ivh  skype-*.rpm


You should have  kernel-desktop-devel and gcc packages first.
#zypper  install  kernel-desktop-devel  gcc

But after you install VMware successful, but you will get error message when you compiled VMware module.
Found some article for openSUSE 12.2 RC2 and Kernel 3.4.x

Install the patch for openSUSE and VMware

# cd   /usr/lib/vmware/modules;

Download  patch
# wget;

Check the  md5 hash

# md5sum   source.tar.lzma;
e37e41a818a47ec868bdb493197aaf63   source.tar.lzma

Extract  source.tar.lzma
# tar   -xf   source.tar.lzma

Install  VMware Module
# vmware-modconfig --console --install-all

It will be success when you install the patch

enjoy it ~~

No comments:

Post a Comment